Skip to main content
CVE-2024-2125VulnerabilityPublished Updated

CVE-2024-2125: EnvíaloSimple: Email Marketing y Newsletters (WordPress plugin) · Unrestricted File Upload

Affects EnvíaloSimple: Email Marketing y Newsletters (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 8.8 High · fixed in 2.4 : patch EnvíaloSimple: Email Marketing y Newsletters (WordPress plugin) soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
dattateccom EnvíaloSimple: Email Marketing y NewslettersAffected
  • =0
Fixed in–

AI-suggested

As of the available information, the CSRF vulnerability has been patched in version 2.4 of the plugin. Administrators should upgrade to version 2.4 or later to address the CSRF aspect. If you cannot patch yet, consider restricting file upload permissions or disabling the plugin if possible to reduce risk.

Description

The EnvíaloSimple: Email Marketing y Newsletters plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.3. This is due to missing or incorrect nonce validation on the gallery_add function. This makes it possible for unauthenticated attackers to upload malicious files via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. The Cross-Site Request Forgery was patched in 2.4, however, nothing was done about the ability to upload arbitrary files.

References

Community reviews

Loading reviews…