Skip to main content
CVE-2024-22027VulnerabilityPublished Updated

CVE-2024-22027: AYS Pro Plugins WordPress Quiz Maker Plugin · Improper input validation

Affects AYS Pro Plugins WordPress Quiz Maker PluginSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 6.5.0.6 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.5.0.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jan 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade AYS Pro Plugins WordPress Quiz Maker Plugin to 6.5.0.6.

Affected software

ProductAffectedFixed in
AYS Pro Plugins WordPress Quiz Maker PluginAffected
  • <6.5.0.6
Fixed in
  • 6.5.0.6

AI-suggested

European organizations should take the following specific steps: 1) Immediately audit WordPress installations to identify the presence and version of the Quiz Maker Plugin and upgrade to version 6.5.0.6 or later once available. 2) Restrict plugin access strictly to trusted users with minimal necessary privileges to reduce the risk of authenticated exploitation. 3) Implement monitoring and alerting on unusual outbound traffic patterns from WordPress servers to detect potential abuse of the plugin's external service calls. 4) Employ web application firewalls (WAFs) with custom rules to limit or block suspicious requests targeting the plugin endpoints. 5) Coordinate with external service providers to prepare for potential DoS conditions and implement rate limiting or filtering on their side if feasible. 6) Regularly review and harden WordPress user roles and permissions to minimize the attack surface. 7) Stay updated with vendor advisories for official patches or mitigation guidance.

Description

Improper input validation vulnerability in WordPress Quiz Maker Plugin prior to 6.5.0.6 allows a remote authenticated attacker to perform a Denial of Service (DoS) attack against external services.

References

Community reviews

Loading reviews…