Skip to main content
CVE-2024-22048VulnerabilityPublished Updated

CVE-2024-22048: govuk_tech_docs · Cross-site Scripting

Affects govuk_tech_docsSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 3.3.1 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jan 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade govuk_tech_docs to 3.3.1.

Affected software

ProductAffectedFixed in
RubyGemsgovuk_tech_docspkg:gem/govuk_tech_docsOther threatsAffected
  • >=2.0.2 <3.3.1
Fixed in
  • 3.3.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should exercise caution when interacting with search results and consider implementing input sanitization or output encoding workarounds if possible.

Description

govuk_tech_docs versions from 2.0.2 to before 3.3.1 are vulnerable to a cross-site scripting vulnerability. Malicious JavaScript may be executed in the user's browser if a malicious search result is displayed on the search page.

References

Community reviews

Loading reviews…