Skip to main content
CVE-2024-22411VulnerabilityPublished Updated

CVE-2024-22411: avo · Cross-site Scripting

Affects avoSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.47.0 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.47.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jan 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade avo to 2.47.0.

Affected software

ProductAffectedFixed in
RubyGemsavopkg:gem/avoOther threatsAffected
  • <2.47.0
Fixed in
  • 2.47.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediate upgrade of all Avo framework instances to version 3.3.0 or later, or 2.47.0 or later, where the vulnerability is patched. 2. Review and audit all custom `Avo::BaseAction` subclasses to ensure that no untrusted input is passed to `error` or `succeed` methods without proper sanitization. 3. Implement Content Security Policy (CSP) headers in the web application to restrict the execution of unauthorized scripts, mitigating the impact of potential XSS attacks. 4. Conduct regular security testing, including automated scanning and manual code reviews, focusing on input handling in admin panel components. 5. Limit user privileges and enforce the principle of least privilege to reduce the risk posed by attackers who gain limited access. 6. Monitor application logs and user activity for unusual behavior that could indicate attempted exploitation. 7. Educate developers and administrators about secure coding practices, especially regarding output encoding and sanitization in web UI components.

Description

Avo is a framework to create admin panels for Ruby on Rails apps. In Avo 3 pre12, any HTML inside text that is passed to `error` or `succeed` in an `Avo::BaseAction` subclass will be rendered directly without sanitization in the toast/notification that appears in the UI on Action completion. A malicious user could exploit this vulnerability to trigger a cross site scripting attack on an unsuspecting user. This issue has been addressed in the 3.3.0 and 2.47.0 releases of Avo. Users are advised to upgrade.

References

Community reviews

Loading reviews…