CVE-2024-22725: n/a
Source CVE Database V5
Not known to be exploited · CVSS 6.1 Medium · fixed in 1.12.2 : update affected systems when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.12.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n/a n/a | Affected
| Fixed in
|
AI-suggested
1. Upgrade Orthanc to version 1.12.2 or later, where this vulnerability has been addressed. 2. If immediate upgrade is not feasible, implement web application firewall (WAF) rules to detect and block suspicious input patterns that could trigger reflected XSS in error messages. 3. Harden server configurations to minimize error message verbosity exposed to users, reducing the risk of reflected input. 4. Educate users and administrators about the risks of clicking on untrusted links, especially those targeting internal medical imaging systems. 5. Conduct regular security assessments and penetration testing focused on web interface vulnerabilities to detect similar issues proactively. 6. Implement Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers accessing the Orthanc server. 7. Monitor logs for unusual access patterns or error requests that could indicate attempted exploitation.
Description
Orthanc versions before 1.12.2 are affected by a reflected cross-site scripting (XSS) vulnerability. The vulnerability was present in the server's error reporting.