CVE-2024-23300: Apple GarageBand · Processing a maliciously crafted file may lead to unexpected app termination or arbitrary code execution
Affects Apple GarageBandSource CVE Database V5
Not known to be exploited · CVSS 7.8 High · fixed in 10.4.11 : patch Apple GarageBand soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.4.11
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Mar 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apple GarageBand | Affected
| Fixed in– |
AI-suggested
Apple has released GarageBand version 10.4.11 which addresses this vulnerability with improved memory management. Users should update to GarageBand 10.4.11 on macOS Ventura or macOS Sonoma to remediate this issue. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2024-23300 is a use-after-free vulnerability in Apple GarageBand that could allow processing a maliciously crafted file to cause unexpected application termination or arbitrary code execution. This issue affects GarageBand versions prior to 10.4.11 on macOS Ventura and macOS Sonoma. Apple addressed the vulnerability by improving memory management in GarageBand 10.4.11, which was released on March 12, 2024. The vulnerability has a CVSS score of 7.8, indicating high severity. No known exploits in the wild have been reported.