CVE-2024-23387: FusionPBX · Cross-site Scripting (XSS)
Affects FusionPBXSource CVE Database V5
Not known to be exploited · CVSS 4.8 Medium : upgrade to 5.1.0 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.1.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 19 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade fusionpbx/fusionpbx to 5.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubfusionpbx/fusionpbxpkg:github/fusionpbx/fusionpbxOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should prioritize upgrading FusionPBX installations to version 5.1.0 or later, where this vulnerability is addressed. If you cannot patch yet, organizations should enforce strict access controls to limit administrative privileges only to trusted personnel and implement multi-factor authentication to reduce the risk of credential compromise. Regularly auditing administrative accounts and monitoring logs for unusual activity can help detect potential exploitation attempts. Additionally, employing web application firewalls (WAFs) with rules to detect and block XSS payloads targeting the FusionPBX interface can provide a layer of defense. Network segmentation to isolate telephony management interfaces from general user networks will reduce exposure. Security awareness training for administrators about phishing and credential security is also recommended to prevent initial account compromise. Finally, organizations should prepare incident response plans specific to telephony infrastructure compromise scenarios.
Description
FusionPBX prior to 5.1.0 contains a cross-site scripting vulnerability. If this vulnerability is exploited by a remote authenticated attacker with an administrative privilege, an arbitrary script may be executed on the web browser of the user who is logging in to the product.