CVE-2024-26751: Linux kernel · ARM: ep93xx: Add terminator to gpiod_lookup_table
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 5.4.0-1126.136~18.04.1 : update Linux kernel when convenient.
Data as of 6 Nov 2026, 15:34 UTC
- Patch
- Available – fixed in 5.4.0-1126.136~18.04.1, 5.4.0-1131.138~18.04.1, 5.4.0-1130.139~18.04.1 +56
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Apr 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-6820-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6828-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6820-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-6831-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-6867-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6871-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6892-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6919-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro Realtime 24.04 LTSlinux-raspi-realtimepkg:deb/ubuntu/linux-raspi-realtime?arch=source&distro=realtime/nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSlinux-allwinner-5.19pkg:deb/ubuntu/linux-allwinner-5.19?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSlinux-aws-5.19pkg:deb/ubuntu/linux-aws-5.19?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSlinux-aws-6.2pkg:deb/ubuntu/linux-aws-6.2?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in multiple fixed Linux kernel versions including 5.4.0-1126.136~18.04.1 and later. Users should upgrade to these fixed kernel versions to remediate the issue. No additional mitigation steps are required beyond applying the official kernel updates.
Description
A vulnerability in the ARM ep93xx GPIO driver in the Linux kernel caused by a missing terminator in the gpiod_lookup_table. This flaw leads to an infinite loop in gpio_find() when a non-existent con_id is passed, resulting in a kernel oops (crash). The issue affects certain Linux kernel versions and has been fixed in multiple updated releases.
References
- ubuntu.com/security/CVE-2024-26751 (opens in a new tab)
- git.kernel.org/linus/fdf87a0dc26d0550c60edc911cda42f9afec3557 (opens in a new tab)
- git.kernel.org/stable/c/9e200a06ae2abb321939693008290af32b33dd6e (opens in a new tab)
- git.kernel.org/stable/c/999a8bb70da2946336327b4480824d1691cae1fa (opens in a new tab)
- git.kernel.org/stable/c/70d92abbe29692a3de8697ae082c60f2d21ab482 (opens in a new tab)
- git.kernel.org/stable/c/eec6cbbfa1e8d685cc245cfd5626d0715a127a48 (opens in a new tab)
- git.kernel.org/stable/c/786f089086b505372fb3f4f008d57e7845fff0d8 (opens in a new tab)
- git.kernel.org/stable/c/97ba7c1f9c0a2401e644760d857b2386aa895997 (opens in a new tab)
- git.kernel.org/stable/c/6abe0895b63c20de06685c8544b908c7e413efa8 (opens in a new tab)
- git.kernel.org/stable/c/fdf87a0dc26d0550c60edc911cda42f9afec3557 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-26751 (opens in a new tab)
- ubuntu.com/security/notices/USN-6820-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6828-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6820-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-6831-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-6867-1 (opens in a new tab)