Skip to main content
VulnerabilityPublished Updated

CVE-2024-26763: Linux kernel · dm-crypt: don't modify the data when using authenticated encryption

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.1 High · fixed in 5.4.0-1126.136~18.04.1 : patch Linux kernel soon.

Data as of 6 Nov 2026, 15:33 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.4.0-1126.136~18.04.1, 5.4.0-1131.138~18.04.1, 5.4.0-1130.139~18.04.1 +56
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu Pro Realtime 24.04 LTSlinux-raspi-realtimepkg:deb/ubuntu/linux-raspi-realtime?arch=source&distro=realtime/nobleOther threatsAffected
  • <6.8.0-2002.2
Fixed in
  • 6.8.0-2002.2
Ubuntu 22.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=jammyOther threatsAffected
  • <5.15.0-112.122
Fixed in
  • 5.15.0-112.122
Ubuntu 22.04 LTSlinux-allwinner-5.19pkg:deb/ubuntu/linux-allwinner-5.19?arch=source&distro=jammyOther threatsAffected
  • 5.19.0-1007.7~22.04.1 – 5.19.0-1015.15~22.04.1
8 affected builds
Fixed in–
Ubuntu 22.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=jammyOther threatsAffected
  • <5.15.0-1063.69
Fixed in
  • 5.15.0-1063.69
Ubuntu 22.04 LTSlinux-aws-5.19pkg:deb/ubuntu/linux-aws-5.19?arch=source&distro=jammyOther threatsAffected
  • 5.19.0-1019.20~22.04.1 – 5.19.0-1029.30~22.04.1
10 affected builds
Fixed in–
Ubuntu 22.04 LTSlinux-aws-6.2pkg:deb/ubuntu/linux-aws-6.2?arch=source&distro=jammyOther threatsAffected
  • 6.2.0-1005.5~22.04.1 – 6.2.0-1018.18~22.04.1
14 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in multiple updated Linux kernel versions. Users should upgrade to the fixed kernel versions listed in the advisory to remediate this vulnerability. No additional mitigation is required beyond applying the official kernel updates.

Description

CVE-2024-26763 is a vulnerability in the Linux kernel's dm-crypt subsystem where data could be modified during authenticated encryption, potentially producing invalid authentication tags. The issue arises when data is encrypted and simultaneously modified with O_DIRECT writes, risking device corruption. The fix involves copying data into a clone bio before encryption, which may reduce performance but prevents data corruption.

References

Community reviews

Loading reviews…