CVE-2024-26878: Linux kernel · quota: Fix potential NULL pointer dereference
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 4.7 Medium · fixed in 5.4.0-1128.138~18.04.1 : update Linux kernel when convenient.
Data as of 6 Nov 2026, 15:33 UTC
- Patch
- Available – fixed in 5.4.0-1128.138~18.04.1, 5.4.0-1133.140~18.04.1, 5.4.0-1132.141~18.04.1 +65
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Apr 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-6816-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6820-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6828-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6820-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-6871-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading to one of the fixed Linux kernel versions listed (e.g., 5.4.0-1128.138~18.04.1 and later). Users should update their Linux kernel to a fixed version to remediate this issue. No additional mitigation steps are indicated by the vendor advisory.
Description
A potential NULL pointer dereference vulnerability was identified and fixed in the Linux kernel quota subsystem. The issue arises from a race condition where quota pointers may be checked before being set to NULL, leading to a NULL pointer dereference. This flaw could cause a denial of service by crashing the system. The vulnerability affects certain Linux kernel versions prior to fixed releases. A patch is available to address this issue.
References
- ubuntu.com/security/CVE-2024-26878 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-26878 (opens in a new tab)
- git.kernel.org/linus/d0aa72604fbd80c8aabb46eda00535ed35570f1f (opens in a new tab)
- git.kernel.org/stable/c/8514899c1a4edf802f03c408db901063aa3f05a1 (opens in a new tab)
- git.kernel.org/stable/c/49669f8e7eb053f91d239df7b1bfb4500255a9d0 (opens in a new tab)
- git.kernel.org/stable/c/61380537aa6dd32d8a723d98b8f1bd1b11d8fee0 (opens in a new tab)
- git.kernel.org/stable/c/1ca72a3de915f87232c9a4cb9bebbd3af8ed3e25 (opens in a new tab)
- git.kernel.org/stable/c/7f9e833fc0f9b47be503af012eb5903086939754 (opens in a new tab)
- git.kernel.org/stable/c/40a673b4b07efd6f74ff3ab60f38b26aa91ee5d5 (opens in a new tab)
- git.kernel.org/stable/c/f2649d98aa9ca8623149b3cb8df00c944f5655c7 (opens in a new tab)
- git.kernel.org/stable/c/6afc9f4434fa8063aa768c2bf5bf98583aee0877 (opens in a new tab)
- git.kernel.org/stable/c/d0aa72604fbd80c8aabb46eda00535ed35570f1f (opens in a new tab)
- ubuntu.com/security/notices/USN-6816-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6820-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6828-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6820-2 (opens in a new tab)