CVE-2024-27028: Linux kernel · spi: spi-mt65xx: Fix NULL pointer access in interrupt handler
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium · fixed in 5.4.0-1128.138~18.04.1 : update Linux kernel when convenient.
Data as of 6 Nov 2026, 15:21 UTC
- Patch
- Available – fixed in 5.4.0-1128.138~18.04.1, 5.4.0-1133.140~18.04.1, 5.4.0-1132.141~18.04.1 +65
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 1 May 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-6816-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6820-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6828-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6820-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-6871-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in fixed Linux kernel versions including 5.4.0-1128.138~18.04.1 and later. Users should upgrade to these fixed kernel versions to remediate the vulnerability. No additional mitigation steps are required beyond applying the official kernel updates.
Description
A NULL pointer dereference vulnerability was identified and fixed in the spi-mt65xx driver of the Linux kernel. The issue occurs because the TX buffer in spi_transfer can be NULL, and the interrupt handler may attempt to write to this invalid memory, causing system crashes. The fix adds a check for the TX buffer before use to prevent this. This vulnerability affects certain versions of the Linux kernel, particularly those used in Ubuntu 18.04 and related distributions.
References
- ubuntu.com/security/CVE-2024-27028 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-27028 (opens in a new tab)
- git.kernel.org/linus/a20ad45008a7c82f1184dc6dee280096009ece55 (opens in a new tab)
- git.kernel.org/stable/c/2342b05ec5342a519e00524a507f7a6ea6791a38 (opens in a new tab)
- git.kernel.org/stable/c/55f8ea6731aa64871ee6aef7dba53ee9f9f3b2f6 (opens in a new tab)
- git.kernel.org/stable/c/bcfcdf19698024565eff427706ebbd8df65abd11 (opens in a new tab)
- git.kernel.org/stable/c/c10fed329c1c104f375a75ed97ea3abef0786d62 (opens in a new tab)
- git.kernel.org/stable/c/766ec94cc57492eab97cbbf1595bd516ab0cb0e4 (opens in a new tab)
- git.kernel.org/stable/c/62b1f837b15cf3ec2835724bdf8577e47d14c753 (opens in a new tab)
- git.kernel.org/stable/c/bea82355df9e1c299625405b1947fc9b26b4c6d4 (opens in a new tab)
- git.kernel.org/stable/c/1784053cf10a14c4ebd8a890bad5cfe1bee51713 (opens in a new tab)
- git.kernel.org/stable/c/a20ad45008a7c82f1184dc6dee280096009ece55 (opens in a new tab)
- ubuntu.com/security/notices/USN-6816-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6820-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6821-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6817-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6828-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6820-2 (opens in a new tab)