Skip to main content
VulnerabilityPublished Updated

CVE-2024-27282: ruby · Out-of-bounds Read

Affects rubySource CVE Database V5

0

Not known to be exploited · CVSS 6.6 Medium · fixed in 3.3.1 : update ruby when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
6.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.3.1, 3.2.4, 3.1.5 +1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ruby to 3.3.1, 3.2.4, 3.1.5 or 3.0.7.

Affected software

ProductAffectedFixed in
RubyGemsrubypkg:gem/rubyOther threatsAffected
  • <3.0.7
  • >=3.0.7 <3.1.5
  • >=3.1.5 <3.2.4
  • >=3.2.4 <3.3.1
Fixed in
  • 3.0.7
  • 3.1.5
  • 3.2.4
  • 3.3.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade Ruby installations to the fixed versions: 3.0.7, 3.1.5, 3.2.4, or 3.3.1, depending on their current version. Where immediate patching is not feasible, restrict access to systems running vulnerable Ruby versions to trusted users only and monitor for unusual regex compilation activities or anomalous user input patterns. Implement input validation and sanitization to limit attacker-controlled data reaching the regex compiler. Employ runtime application self-protection (RASP) or memory protection tools to detect and prevent out-of-bounds memory reads. Conduct code reviews and security testing focused on regex usage in applications. Additionally, audit logs for suspicious user interactions that could indicate exploitation attempts. For critical systems, consider isolating Ruby processes or running them with minimal privileges to reduce the attack surface. Finally, maintain an up-to-date inventory of Ruby versions in use across the organization to ensure comprehensive remediation.

Description

An issue was discovered in Ruby 3.x through 3.3.0. If attacker-supplied data is provided to the Ruby regex compiler, it is possible to extract arbitrary heap data relative to the start of the text, including pointers and sensitive strings. The fixed versions are 3.0.7, 3.1.5, 3.2.4, and 3.3.1.

References

Community reviews

Loading reviews…