CVE-2024-27396: Linux kernel · net: gtp: Fix Use-After-Free in gtp_dellink
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.4.0-1128.138~18.04.1 : patch Linux kernel soon.
Data as of 6 Nov 2026, 15:18 UTC
- Patch
- Available – fixed in 5.4.0-1128.138~18.04.1, 5.4.0-1133.140~18.04.1, 5.4.0-1132.141~18.04.1 +73
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 May 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-6896-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6898-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6896-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6898-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6896-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-6898-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-6896-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-6896-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-6898-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-6917-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6919-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6927-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in multiple fixed Linux kernel versions including 5.4.0-1128.138~18.04.1 and later. Users and administrators should update affected systems to these fixed kernel versions to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2024-27396 is a use-after-free vulnerability in the Linux kernel's GTP (GPRS Tunneling Protocol) implementation. The issue arises because call_rcu is called outside the RCU read critical section during traversal in gtp_dellink, allowing the key to be freed prematurely. This flaw has been fixed by changing the traversal method to a safe variant. The vulnerability affects multiple Linux kernel versions, particularly those used in Ubuntu Azure kernels prior to specific fixed releases. The CVSS score is 7.8, indicating high severity with potential for confidentiality, integrity, and availability impact. A patch is available and has been released in various fixed kernel versions.
References
- ubuntu.com/security/CVE-2024-27396 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-27396 (opens in a new tab)
- git.kernel.org/linus/f2a904107ee2b647bb7794a1a82b67740d7c8a64 (opens in a new tab)
- ubuntu.com/security/notices/USN-6896-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6898-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6896-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6898-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6896-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-6898-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-6896-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-6896-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-6898-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-6917-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6919-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6927-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6949-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6952-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6955-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6949-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6952-2 (opens in a new tab)