CVE-2024-29271: VvvebJs · n/a
Affects VvvebJsSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.7.7 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.7.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Mar 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade givanz/VvvebJs to 1.7.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubgivanz/VvvebJspkg:github/givanz/VvvebJsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2024-29271, organizations should upgrade VvvebJs to version 1.7.7 or later where the vulnerability is patched. If immediate upgrading is not feasible, implement strict input validation and output encoding on the 'action' parameter in save.php to neutralize malicious scripts. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers. Additionally, use HTTP-only and secure flags on cookies to reduce the risk of token theft. Educate users and developers about the risks of clicking untrusted links and the importance of verifying URLs. Conduct regular security assessments and code reviews focusing on input handling and sanitization. Monitor web server logs for suspicious requests targeting the vulnerable parameter. Finally, consider implementing web application firewalls (WAFs) with rules to detect and block reflected XSS payloads targeting this endpoint.
Description
Reflected Cross-Site Scripting (XSS) vulnerability in VvvebJs before version 1.7.7, allows remote attackers to execute arbitrary code and obtain sensitive information via the action parameter in save.php.