CVE-2024-31497: putty · n/a
Affects puttySource CVE Database V5
Not known to be exploited · CVSS 5.9 Medium : upgrade to 0.81 when convenient.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 5.7% chance of exploitation in 30 days – higher than 92% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.81, 3.67.0, 6.3.3 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Apr 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubputty/puttypkg:github/putty/puttyOther threats | Affected
| Fixed in
|
GitHubfilezilla-project/filezillapkg:github/filezilla-project/filezillaOther threats | Affected
| Fixed in
|
GitHubwinscp/winscppkg:github/winscp/winscpOther threats | Affected
| Fixed in
|
GitHubtortoisegit/tortoisegitpkg:github/tortoisegit/tortoisegitOther threats | Affected
| Fixed in
|
GitHubtortoisesvn/tortoisesvnpkg:github/tortoisesvn/tortoisesvnOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2024-31497, European organizations should immediately update all affected software to versions that have patched the biased nonce generation issue: PuTTY 0.81 or later, FileZilla 3.67.0 or later, WinSCP 6.3.3 or later, TortoiseGit 2.15.0.1 or later, and TortoiseSVN versions beyond 1.14.6. Organizations should audit their use of NIST P-521 ECDSA keys, especially those used for SSH authentication and Git commit signing, and consider generating new keys with secure nonce generation. Avoid reusing the same private key across multiple services to limit the impact of a potential compromise. Disable SSH agent forwarding where not strictly necessary, or restrict it to trusted servers only, to reduce exposure to rogue SSH servers. Review and restrict access to signed messages stored in public or semi-public repositories to minimize signature leakage. Implement monitoring for unusual SSH authentication patterns and unauthorized Git commits that could indicate key compromise. Educate developers and system administrators about the risks of key reuse and the importance of timely patching. Finally, consider adopting alternative cryptographic algorithms or key types less susceptible to nonce-related vulnerabilities, such as Ed25519, where feasible.
Description
In PuTTY 0.68 through 0.80 before 0.81, biased ECDSA nonce generation allows an attacker to recover a user's NIST P-521 secret key via a quick attack in approximately 60 signatures. This is especially important in a scenario where an adversary is able to read messages signed by PuTTY or Pageant. The required set of signed messages may be publicly readable because they are stored in a public Git service that supports use of SSH for commit signing, and the signatures were made by Pageant through an agent-forwarding mechanism. In other words, an adversary may already have enough signature information to compromise a victim's private key, even if there is no further use of vulnerable PuTTY versions. After a key compromise, an adversary may be able to conduct supply-chain attacks on software maintained in Git. A second, independent scenario is that the adversary is an operator of an SSH server to which the victim authenticates (for remote login or file copy), even though this server is not fully trusted by the victim, and the victim uses the same private key for SSH connections to other services operated by other entities. Here, the rogue server operator (who would otherwise have no way to determine the victim's private key) can derive the victim's private key, and then use it for unauthorized access to those other services. If the other services include Git services, then again it may be possible to conduct supply-chain attacks on software maintained in Git. This also affects, for example, FileZilla before 3.67.0, WinSCP before 6.3.3, TortoiseGit before 2.15.0.1, and TortoiseSVN through 1.14.6.
References
- chiark.greenend.org.uk/~sgtatham/putty/changes.html (opens in a new tab)
- filezilla-project.org/versions.php (opens in a new tab)
- chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-p521-bias.html (opens in a new tab)
- openwall.com/lists/oss-security/2024/04/15/6 (opens in a new tab)
- tartarus.org/~simon/putty-snapshots/htmldoc/Chapter9.html (opens in a new tab)
- docs.ccv.brown.edu/oscar/connecting-to-oscar/ssh/ssh-agent-forwarding/key-generation-and-agent-forwarding-with-putty (opens in a new tab)
- news.ycombinator.com/item?id=40044665 (opens in a new tab)
- winscp.net/eng/news.php (opens in a new tab)
- tortoisegit.org (opens in a new tab)
- github.com/advisories/GHSA-6p4c-r453-8743 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2275183 (opens in a new tab)
- bugzilla.suse.com/show_bug.cgi?id=1222864 (opens in a new tab)
- security-tracker.debian.org/tracker/CVE-2024-31497 (opens in a new tab)
- twitter.com/lambdafu/status/1779969509522133272 (opens in a new tab)
- git.tartarus.org (opens in a new tab)
- reddit.com/r/sysadmin/comments/1c4wmoj/putty_vulnerability_affecting_v068_to_v08/ (opens in a new tab)
- github.com/daedalus/BreakingECDSAwithLLL (opens in a new tab)
- bleepingcomputer.com/news/security/putty-ssh-client-flaw-allows-recovery-of-cryptographic-private-keys/ (opens in a new tab)
- twitter.com/CCBalert/status/1780229237569470549 (opens in a new tab)
- securityonline.info/cve-2024-31497-critical-putty-vulnerability-exposes-private-keys-immediate-action-required/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WMJH7M663BVO3SY6MFAW2FAZWLLXAPRQ/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MMHILY2K7HQGQRHOC375KRRG2M6625RD/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IZS3B37GNGWOOV7QU7B7JFK76U4TOP4V/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WFDZBV7ZCAZ6AH3VCQ34SSY7L3J7VZXZ/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PUOTQVGC4DISVHQGSPUYGXO6TLDK65LA/ (opens in a new tab)
- openwall.com/lists/oss-security/2024/04/15/6 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/06/msg00014.html (opens in a new tab)
- vicarius.io/vsociety/posts/understanding-a-critical-vulnerability-in-putty-biased-ecdsa-nonce-generation-revealing-nist-p-521-private-keys-cve-2024-31497 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PUOTQVGC4DISVHQGSPUYGXO6TLDK65LA/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/IZS3B37GNGWOOV7QU7B7JFK76U4TOP4V/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WMJH7M663BVO3SY6MFAW2FAZWLLXAPRQ/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MMHILY2K7HQGQRHOC375KRRG2M6625RD/ (opens in a new tab)