Skip to main content
VulnerabilityPublished Updated

CVE-2024-32475: envoyproxy envoy · Incorrect Check of Function Return Value

Affects envoyproxy envoySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High · fixed in 1.30.1 : patch envoyproxy envoy soon.

Data as of 5 Nov 2026, 16:17 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.5
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2024-04-23.

Patch
Available – fixed in 1.30.1, 1.29.4, 1.28.3 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade envoyproxy envoy to 1.30.1, 1.29.4, 1.28.3 or 1.27.5.

Affected software

ProductAffectedFixed in
envoyproxyenvoyAffected
  • >=1.30.0 <1.30.1
Fixed in
  • 1.30.1
envoyproxyenvoyAffected
  • >=1.29.0 <1.29.4
Fixed in
  • 1.29.4
envoyproxyenvoyAffected
  • >=1.28.0 <1.28.3
Fixed in
  • 1.28.3
envoyproxyenvoyAffected
  • >=1.13.0 <1.27.5
Fixed in
  • 1.27.5

AI-suggested

Upgrade Envoy to one of the fixed versions: 1.30.1, 1.29.4, 1.28.3, or 1.27.5. These versions include the fix that properly handles errors when setting the SNI for outbound TLS connections. Until upgraded, consider disabling auto_sni or implementing input validation to reject requests with host or :authority headers longer than 255 characters to prevent triggering the crash.

Description

CVE-2024-32475 is a vulnerability in Envoy proxy where an upstream TLS cluster with auto_sni enabled can cause the Envoy process to terminate abnormally if a request contains a host or :authority header longer than 255 characters. This happens because Envoy attempts to use the header value as the SNI for outbound TLS connections without properly handling errors when the SNI length exceeds the 255-character limit defined by the standard. The issue is fixed in versions 1.30.1, 1.29.4, 1.28.3, and 1.27.5.

References

Community reviews

Loading reviews…