Skip to main content
CVE-2024-34500VulnerabilityPublished Updated

CVE-2024-34500: UnlinkedWikibase · n/a

Affects UnlinkedWikibaseSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium · fixed in 1.41.1 : update UnlinkedWikibase when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.41.1, 1.40.2, 1.39.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade mediawiki/extensions/UnlinkedWikibase to 1.41.1, 1.40.2 or 1.39.6.

Affected software

ProductAffectedFixed in
GitHubmediawiki/extensions/UnlinkedWikibasepkg:github/mediawiki/extensions/UnlinkedWikibaseOther threatsAffected
  • <1.39.6
  • 1.40.0 <1.40.2
  • 1.41.0 <1.41.1
Fixed in
  • 1.39.6
  • 1.40.2
  • 1.41.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately verify if their MediaWiki installations use the UnlinkedWikibase extension and identify the version in use. Upgrading to MediaWiki versions 1.39.6, 1.40.2, or 1.41.1 and later is the primary mitigation step to eliminate this vulnerability. If immediate upgrading is not feasible, organizations should implement strict Content Security Policy (CSP) headers to restrict script execution and reduce the impact of XSS. Additionally, administrators should audit interface messages and error handling code to ensure proper escaping and sanitization of user-controllable inputs. User awareness training to recognize suspicious links or messages can reduce the risk of social engineering exploitation. Monitoring web server logs for unusual requests targeting interface messages or error generation endpoints can help detect attempted exploitation. Finally, consider isolating MediaWiki instances behind VPNs or internal networks to limit exposure to external attackers.

Description

An issue was discovered in the UnlinkedWikibase extension in MediaWiki before 1.39.6, 1.40.x before 1.40.2, and 1.41.x before 1.41.1. XSS can occur through an interface message. Error messages (in the $err var) are not escaped before being passed to Html::rawElement() in the getError() function in the Hooks class.

References

Community reviews

Loading reviews…