CVE-2024-3502: lunary-ai/lunary · Insertion of Sensitive Information Into Sent Data
Affects lunary-ai/lunarySource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical · fixed in 1.2.6 : patch lunary-ai/lunary as a priority.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.2.6
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Nov 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHublunary-ai/lunarypkg:github/lunary-ai/lunaryOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations using lunary-ai/lunary should immediately upgrade to version 1.2.6 or later, where the vulnerability is patched. Until the upgrade is applied, restrict access to the affected API endpoints to only trusted and necessary users, and monitor API usage logs for unusual access patterns or attempts to retrieve sensitive data. Implement strong authentication and session management controls to limit the risk of unauthorized authenticated access. Conduct thorough audits of account recovery mechanisms to ensure no other sensitive information is exposed. Additionally, educate users about phishing and social engineering risks that could exploit leaked recovery information. Employ network segmentation and least privilege principles to minimize the impact of any compromised accounts. Finally, maintain an incident response plan to quickly address any suspected account compromises.
Description
In lunary-ai/lunary versions up to and including 1.2.5, an information disclosure vulnerability exists where account recovery hashes of users are inadvertently exposed to unauthorized actors. This issue occurs when authenticated users inspect responses from `GET /v1/users/me` and `GET /v1/users/me/org` endpoints. The exposed account recovery hashes, while not directly related to user passwords, represent sensitive information that should not be accessible to unauthorized parties. Exposing these hashes could potentially facilitate account recovery attacks or other malicious activities. The vulnerability was addressed in version 1.2.6.