CVE-2024-35164: Apache Guacamole · Improper Validation of Array Index
Affects Apache GuacamoleSource CVE Database V5
Not known to be exploited · CVSS 6.8 Medium · fixed in 1.6.0 : update Apache Guacamole when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.6.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.guacamole/guacamolepkg:maven/org.apache.guacamole/guacamoleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2024-35164, organizations should immediately upgrade Apache Guacamole to version 1.6.0 or later, where the vulnerability has been fixed. In addition to patching, administrators should restrict network access to Guacamole instances by implementing strict firewall rules and network segmentation to limit exposure of text-based protocol ports such as SSH. Employing multi-factor authentication and strong access controls on Guacamole user accounts can reduce the risk of unauthorized access. Monitoring and logging of Guacamole sessions should be enhanced to detect anomalous or suspicious console code sequences or unexpected process behavior. Where feasible, running the guacd process with the least privileges necessary and within containerized or sandboxed environments can limit the impact of potential exploitation. Regularly reviewing and updating security policies related to remote access infrastructure will further strengthen defenses against similar vulnerabilities.
Description
The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.6.0, which fixes this issue.