Skip to main content
VulnerabilityPublished Updated

CVE-2024-35948: Linux kernel · bcachefs: Check for journal entries overruning end of sb clean section

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · CVSS 8.4 High : upgrade to 6.8.0-1035.38 soon.

Data as of 6 Nov 2026, 15:17 UTC

CVSS 3.1 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.8.0-1035.38
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade the Ubuntu linux-nvidia-tegra package to 6.8.0-1035.38.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • 6.5.0-9.9 – 6.8.0-149.149
60 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • 6.5.0-1008.8 – 6.8.0-1069.74
56 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • 6.5.0-1007.7 – 6.8.0-1071.79
46 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=nobleOther threatsAffected
  • 6.8.0-1041.48 – 6.8.0-1069.76
13 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-azure-nvidiapkg:deb/ubuntu/linux-azure-nvidia?arch=source&distro=nobleOther threatsAffected
  • 6.8.0-1013.14 – 6.8.0-1039.42
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • 6.5.0-1007.7 – 6.8.0-1073.81
58 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch addressing this vulnerability is available in Linux kernel version 6.8.0-1035.38 and later. Users should update their systems to this version or newer to remediate the issue. Since the superblock is checksummed and validated prior to write, and backups exist, no immediate repair code is required. Applying the official kernel updates from the vendor is the recommended mitigation.

Description

CVE-2024-35948 is a high-severity vulnerability in the Linux kernel's bcachefs filesystem. It involves a missing bounds check in the superblock validation process, specifically for journal entries that overrun the end of the superblock clean section. This flaw could lead to corruption or compromise of the filesystem integrity. The issue has been fixed in Linux kernel version 6.8.0-1035.38 and related patched versions. No repair code exists yet for this case, but the superblock is checksummed and validated prior to write, with backups available.

References

Community reviews

Loading reviews…