Skip to main content
CVE-2024-37371VulnerabilityPublished Updated

CVE-2024-37371: krb5 · n/a

Affects krb5Source CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.21.3 as a priority.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.8% chance of exploitation in 30 days – higher than 79% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.21.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade krb5/krb5 to 1.21.3.

Affected software

ProductAffectedFixed in
GitHubkrb5/krb5pkg:github/krb5/krb5Other threatsAffected
  • <1.21.3
Fixed in
  • 1.21.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade MIT Kerberos 5 to version 1.21.3 or later, where this vulnerability is fixed. Patch status is confirmed by the version boundary provided. No other mitigation or workaround is indicated.

Description

In MIT Kerberos 5 (aka krb5) before 1.21.3, an attacker can cause invalid memory reads during GSS message token handling by sending message tokens with invalid length fields.

References

Community reviews

Loading reviews…