CVE-2024-3931: Totara LMS · Cross Site Scripting
Affects Totara LMSSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 18 Apr 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Totara LMS | Affected
| Fixed in– |
AI-suggested
Beyond the generic advice of upgrading to patched versions, European organizations should implement a multi-layered defense strategy. First, immediately apply the recommended Totara LMS updates to versions 13.46, 14.38, 15.33, 16.27, 17.21, or 18.8 to remediate the vulnerability. Second, conduct a thorough review of user input handling and ensure robust input validation and output encoding are enforced throughout the LMS, particularly in custom plugins or integrations. Third, deploy web application firewalls (WAFs) with rules tuned to detect and block XSS attack patterns targeting the affected endpoints. Fourth, implement Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers accessing the LMS. Fifth, educate LMS users about phishing and suspicious links to reduce the risk of social engineering that could trigger XSS payloads. Finally, monitor LMS logs and network traffic for unusual activities indicative of exploitation attempts, and have an incident response plan ready to contain and remediate any breaches.
Description
A vulnerability was found in Totara LMS up to 18.7. It has been rated as problematic. Affected by this issue is some unknown functionality of the file admin/roles/check.php of the component User Selector. The manipulation of the argument ID Number leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 13.46, 14.38, 15.33, 16.27, 17.21 and 18.8 is able to address this issue. It is recommended to upgrade the affected component.