CVE-2024-39480: Linux kernel · kdb: Fix buffer overflow during tab-complete
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 8.4 High · fixed in 4.15.0-1181.196~14.04.1 : patch Linux kernel soon.
Data as of 28 Oct 2026, 11:11 UTC
- Patch
- Available – fixed in 4.15.0-1181.196~14.04.1, 4.15.0-1173.186~16.04.1, 4.15.0-1181.196~16.04.1 +87
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-6951-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6953-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6951-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6951-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-6951-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-6979-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7004-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7007-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7008-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-2 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and included in Linux kernel versions 4.15.0-1181.196 and later for the affected branches. Users should apply the official kernel updates provided by their distribution, such as those from Ubuntu's USN-6951-1 advisory, and reboot their systems to activate the fixes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be necessary. No additional mitigation steps are required beyond applying the official updates.
Description
A buffer overflow vulnerability in the Linux kernel's kdb debugger during tab-completion was fixed. The issue arose because strncpy() was incorrectly used with the source buffer size instead of the destination buffer size, causing potential writes beyond the command buffer boundary. This flaw could lead to memory corruption. The vulnerability affects multiple Linux kernel versions, particularly various linux-azure builds prior to 4.15.0-1181.196 and specific 3.11 and 3.12 kernel versions. A patch replacing strncpy() with safer memory operations and boundary checks is available.
References
- ubuntu.com/security/CVE-2024-39480 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-39480 (opens in a new tab)
- git.kernel.org/linus/e9730744bf3af04cda23799029342aa3cddbc454 (opens in a new tab)
- git.kernel.org/stable/c/fb824a99e148ff272a53d71d84122728b5f00992 (opens in a new tab)
- git.kernel.org/stable/c/ddd2972d8e2dee3b33e8121669d55def59f0be8a (opens in a new tab)
- git.kernel.org/stable/c/cfdc2fa4db57503bc6d3817240547c8ddc55fa96 (opens in a new tab)
- git.kernel.org/stable/c/f636a40834d22e5e3fc748f060211879c056cd33 (opens in a new tab)
- git.kernel.org/stable/c/33d9c814652b971461d1e30bead6792851c209e7 (opens in a new tab)
- git.kernel.org/stable/c/107e825cc448b7834b31e8b1b3cf0f57426d46d5 (opens in a new tab)
- git.kernel.org/stable/c/f694da720dcf795dc3eb97bf76d220213f76aaa7 (opens in a new tab)
- git.kernel.org/stable/c/e9730744bf3af04cda23799029342aa3cddbc454 (opens in a new tab)
- ubuntu.com/security/notices/USN-6951-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6953-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6951-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6951-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-6951-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-6979-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7004-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-1 (opens in a new tab)