CVE-2024-39700: jupyterlab extension-template · Code Injection
Affects jupyterlab extension-templateSource CVE Database V5
Public exploit available · CVSS 10.0 Critical : upgrade to 4.3.3 as a priority.
Data as of 3 Nov 2026, 22:57 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 10.0 |
|---|
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 65% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- Proof of concept is public or traded
- Automatable
- Attackers can reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2024-08-16.
- Patch
- Available – fixed in 4.3.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 16 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CISA SSVC: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by GitHub, Inc.
, 19 days before disclosure
CVE published
on cve.org
, t = 0
CISA SSVC assessment
proof of concept public
, 31 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade jupyterlab extension-template to 4.3.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| jupyterlabextension-template | Affected
| Fixed in
|
AI-suggested
Upgrade all repositories created from the JupyterLab extension-template to version 4.3.3 or later, which includes the fix for this vulnerability. Accept overwriting of the `update-integration-tests.yml` workflow file during the upgrade and re-apply any custom changes afterward. Temporarily disable GitHub Actions workflows while performing the upgrade to prevent exploitation. Rebase all open pull requests from untrusted users to ensure that workflows run the updated, patched version. Users upgrading from versions prior to 4.3.0 should consider leaving out changes to the release workflow until additional configuration is completed.
Description
CVE-2024-39700 is a critical code injection vulnerability (CWE-94) in the JupyterLab extension-template prior to version 4.3.3. The flaw exists in the `update-integration-tests.yml` GitHub Actions workflow included when the template is created with the `test` option. This workflow allows remote code execution (RCE) due to unsafe code injection. Users hosting extensions on GitHub should upgrade to version 4.3.3 or later to remediate this issue. Temporary mitigation includes disabling GitHub Actions and rebasing pull requests from untrusted users to avoid running vulnerable workflows. The vulnerability has a CVSS 3.1 score of 10.0, indicating critical severity with network attack vector, low attack complexity, and high impact on confidentiality, integrity, and availability.