Skip to main content
VulnerabilityPublished Updated

CVE-2024-40637: dbt-core · Injection

Affects dbt-coreSource GCVE Database

0
Compare

Not known to be exploited · CVSS 4.2 Medium : upgrade to 1.7.14 or 1.6.14 when convenient.

Data as of 30 Oct 2026, 15:35 UTC

CVSS 3.1 base score
4.2Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.14.2
Patch
Available – fixed in 1.7.14, 1.6.14
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade dbt-core to 1.7.14 or 1.6.14.

Affected software

ProductAffectedFixed in
dbt-labs dbt-coreAffected
  • <1.6.14
  • >=1.7.0 <1.7.14
Fixed in
  • 1.6.14
  • 1.7.14

AI-suggested

Users should upgrade to dbt-core versions 1.6.14 or 1.7.14 to remediate this vulnerability. After upgrading, users must set 'flags.require_explicit_package_overrides_for_builtin_materializations: False' in the dbt_project.yml configuration file to maintain compatibility. There are no known workarounds. Applying the official fix is the recommended mitigation.

Description

CVE-2024-40637 is an injection vulnerability in dbt-labs dbt-core that arises because installed packages can override core components such as macros and materializations. This design feature allows customization but also enables malicious packages to inject harmful code. The vulnerability affects versions prior to 1.6.14 and versions from 1.7.0 up to but not including 1.7.14. Fixed versions are 1.6.14 and 1.7.14. Users upgrading to 1.6.14 or 1.7.14 must set a specific configuration flag to maintain compatibility. The CVSS score is 4.2 (medium severity).

References

Community reviews

Loading reviews…