CVE-2024-40965: Linux kernel · i2c: lpi2c: Avoid calling clk_get_rate during transfer
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 5.4.0-1142.152~18.04.1 : update Linux kernel when convenient.
Data as of 6 Nov 2026, 15:12 UTC
- Patch
- Available – fixed in 5.4.0-1142.152~18.04.1, 5.4.0-1145.152~18.04.1, 5.4.0-1143.152~18.04.1 +71
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-6999-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7004-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7008-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7029-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7288-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7289-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7291-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7288-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7289-2 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in multiple Linux kernel versions including 5.4.0-1142.152~18.04.1 and later. Users should upgrade to one of the fixed kernel versions to remediate this issue. No additional mitigation steps are required beyond applying the official kernel updates.
Description
CVE-2024-40965 is a medium-severity vulnerability in the Linux kernel's i2c lpi2c driver. The issue involves a deadlock caused by repeatedly calling clk_get_rate during transfers, which leads to a mutex lock conflict when adding certain audio codecs like tlv320aic32x4. This deadlock can cause denial of service by system hang or crash. The vulnerability affects specific Linux kernel versions prior to fixed releases in the 5.4.0 series and others. A patch is available and has been incorporated into multiple fixed kernel versions.
References
- ubuntu.com/security/CVE-2024-40965 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-40965 (opens in a new tab)
- git.kernel.org/linus/4268254a39484fc11ba991ae148bacbe75d9cc0a (opens in a new tab)
- git.kernel.org/stable/c/2b42e9587a7a9c7b824e0feb92958f258263963e (opens in a new tab)
- git.kernel.org/stable/c/4268254a39484fc11ba991ae148bacbe75d9cc0a (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7004-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7008-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7005-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-6999-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7029-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7288-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7289-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7291-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7288-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7289-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7293-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7294-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7295-1 (opens in a new tab)