Skip to main content
VulnerabilityPublished Updated

CVE-2024-41177: Apache Zeppelin · Cross-site Scripting

Affects Apache ZeppelinSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 0.12.0 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.12.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade apache/zeppelin to 0.12.0.

Affected software

ProductAffectedFixed in
GitHubapache/zeppelinpkg:github/apache/zeppelinOther threatsAffected
  • <0.12.0
Fixed in
  • 0.12.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade Apache Zeppelin to version 0.12.0 or later, where the vulnerability is fixed. Organizations should prioritize this upgrade in their patch management cycles. In addition to patching, implementing strict Content Security Policies (CSP) can help mitigate the impact of potential XSS attacks by restricting the execution of unauthorized scripts. Zeppelin administrators should review and harden access controls to limit exposure to trusted users only, reducing the attack surface. Monitoring web server logs and user activity for unusual patterns or suspicious requests can help detect attempted exploitation. Employing web application firewalls (WAFs) with rules targeting XSS attack patterns can provide an additional layer of defense. Educating users about the risks of interacting with untrusted content within Zeppelin notebooks can reduce the likelihood of successful exploitation. Finally, organizations should ensure that Zeppelin instances are not unnecessarily exposed to the public internet and are protected within secure network segments.

Description

Incomplete Blacklist to Cross-Site Scripting vulnerability in Apache Zeppelin. This issue affects Apache Zeppelin: before 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue.

References

Community reviews

Loading reviews…