Skip to main content
VulnerabilityPublished Updated

CVE-2024-43802: vim · Heap-based Buffer Overflow

Affects vimSource GCVE Database

0
Compare

Not known to be exploited · CVSS 4.5 Medium : upgrade to 9.1.0697 when convenient.

Data as of 30 Oct 2026, 00:26 UTC

CVSS 3.1 base score
4.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.14.5
Patch
Available – fixed in 9.1.0697
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade vim to 9.1.0697.

Affected software

ProductAffectedFixed in
vim vimAffected
  • <9.1.0697
Fixed in
  • 9.1.0697

AI-suggested

Upgrade Vim to version 9.1.0697 or later, where the vulnerability is fixed. There are no known workarounds for this issue. Users should apply the official patch to prevent crashes caused by this buffer overflow.

Description

CVE-2024-43802 is a heap-based buffer overflow vulnerability in Vim, an improved version of the Unix vi text editor. The flaw occurs when flushing the typeahead buffer: Vim advances the buffer position without verifying sufficient space remains, potentially causing the position to point outside the valid buffer. This can lead to a heap buffer overflow and crash. The issue appears under specific conditions involving error messages combined with multiple long mappings. The vulnerability has been fixed in Vim patch version 9.1.0697. Users should upgrade to this version or later. No workarounds are known.

References

Community reviews

Loading reviews…