CVE-2024-47814: vim · Use After Free
Affects vimSource GCVE Database
Not known to be exploited · CVSS 3.9 Low : upgrade to 9.1.0764 when convenient.
Data as of 30 Oct 2026, 00:27 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 3.9 |
|---|
- Patch
- Available – fixed in 9.1.0764
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 7 Oct 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade vim to 9.1.0764.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vim vim | Affected
| Fixed in
|
AI-suggested
Users should upgrade to Vim version 9.1.0764 or later, where this vulnerability is fixed. There are no known workarounds for this issue.
Description
CVE-2024-47814 is a use-after-free vulnerability in Vim versions prior to 9.1.0764. It occurs when closing a buffer visible in a window if a BufWinLeave auto command re-opens the same buffer in a new split window. This can lead to a crash. The vulnerability requires a deliberately configured auto command and specific buffer unload actions, limiting its impact. The issue is fixed in Vim 9.1.0764. No workarounds are known.
References
- github.com/vim/vim/security/advisories/GHSA-rj48-v4mq-j4vg (opens in a new tab)
- github.com/vim/vim/commit/51b62387be93c65fa56bbabe1c3 (opens in a new tab)
- security.netapp.com/advisory/ntap-20250411-0009/ (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/03/msg00023.html (opens in a new tab)