Skip to main content
VulnerabilityPublished Updated

CVE-2024-44082: OpenStack Ironic · Missing Authorization

Source CVE Database V5

0

Not known to be exploited · CVSS 4.3 Medium · fixed in 26.0.1 : update OpenStack Ironic when convenient.

Data as of 26 Oct 2026, 12:54 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Affects
OpenStack Ironic before 26.0.1
Patch
Available – fixed in 26.0.1, 24.1.2, 23.0.2 +5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

AI-suggested

To mitigate CVE-2024-44082, organizations should promptly upgrade OpenStack Ironic to version 26.0.1 or later and ironic-python-agent to version 9.13.1 or later, where the vulnerability has been addressed. If you cannot patch yet, restrict access to the Ironic API and ironic-python-agent interfaces to trusted and minimal user groups to reduce the risk of exploitation by unauthorized or less trusted users. Implement strict authentication and authorization controls to ensure only fully vetted users can upload or manipulate images. Monitor logs for unusual image processing activities or access patterns that could indicate exploitation attempts. Additionally, consider isolating the provisioning environment from general user networks to limit exposure. Regularly audit and review user privileges and credentials to prevent misuse by insiders or compromised accounts. Finally, stay informed on any emerging exploit reports or updates from OpenStack security advisories.

Description

In OpenStack Ironic before 26.0.1 and ironic-python-agent before 9.13.1, there is a vulnerability in image processing, in which a crafted image could be used by an authenticated user to exploit undesired behaviors in qemu-img, including possible unauthorized access to potentially sensitive data. The affected/fixed version details are: Ironic: <21.4.3, >=22.0.0 <23.0.2, >=23.1.0 <24.1.2, >=25.0.0 <26.0.1; Ironic-python-agent: <9.4.2, >=9.5.0 <9.7.1, >=9.8.0 <9.11.1, >=9.12.0 <9.13.1.

References

Community reviews

Loading reviews…