Skip to main content
VulnerabilityPublished Updated

CVE-2024-45008: Linux kernel · Input: MT – limit max slots

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 5.5 Medium · fixed in 5.4.0-1135.145~18.04.1 : update Linux kernel when convenient.

Data as of 27 Oct 2026, 00:01 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.4.0-1135.145~18.04.1, 5.4.0-1140.147~18.04.1, 5.4.0-1139.148~18.04.1 +75
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-50.51
Fixed in
  • 6.8.0-50.51
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1020.22
Fixed in
  • 6.8.0-1020.22
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1020.23
Fixed in
  • 6.8.0-1020.23
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1019.21
Fixed in
  • 6.8.0-1019.21
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1015.19
Fixed in
  • 6.8.0-1015.19
Ubuntu 24.04 LTSlinux-gkeoppkg:deb/ubuntu/linux-gkeop?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1002.4
Fixed in
  • 6.8.0-1002.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading to the fixed Linux kernel versions listed in the advisory (e.g., 5.4.0-1135.145~18.04.1 and later). Users should update their systems to these patched kernel versions to mitigate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2024-45008 is a vulnerability in the Linux kernel's input subsystem where the maximum number of multitouch (MT) slots was not properly limited. This flaw allowed userspace to supply an excessively large number of slots via ioctl(UI_DEV_CREATE), potentially causing resource exhaustion. The issue has been addressed by limiting the maximum slots to 1024. The vulnerability affects multiple Linux kernel versions prior to the fixed releases in the 5.4.x series and some older versions. The CVSS score is 5.5 (medium severity) with an impact on availability due to potential denial of service. A patch is available and has been incorporated into various fixed kernel versions.

References

Community reviews

Loading reviews…