CVE-2024-46750: Linux kernel · PCI: Add missing bridge lock to pci_bus_lock()
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.4.0-1135.145~18.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 23:59 UTC
- Patch
- Available – fixed in 5.4.0-1135.145~18.04.1, 5.4.0-1140.147~18.04.1, 5.4.0-1139.148~18.04.1 +75
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 18 Sep 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7088-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7100-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7100-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-7119-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7123-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7144-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7154-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7155-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkeoppkg:deb/ubuntu/linux-gkeop?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in multiple Linux kernel versions including 5.4.0-1135.145~18.04.1 and later. Users should update their Linux kernel to one of the fixed versions listed in the advisory to remediate this vulnerability. No additional mitigation is required once the system is updated.
Description
CVE-2024-46750 is a high-severity vulnerability in the Linux kernel's PCI subsystem where a missing bridge lock in pci_bus_lock() could lead to unsafe secondary bus resets. This flaw was identified through lock dependency analysis and fixed by adding the missing pci_dev_lock() call to properly lock the PCI bridge device during bus resets. The issue affects multiple Linux kernel versions prior to the fixed releases and could allow local attackers with limited privileges to cause system compromise.
References
- ubuntu.com/security/CVE-2024-46750 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-46750 (opens in a new tab)
- git.kernel.org/linus/a4e772898f8bf2e7e1cf661a12c60a5612c4afab (opens in a new tab)
- git.kernel.org/stable/c/0790b89c7e911003b8c50ae50e3ac7645de1fae9 (opens in a new tab)
- git.kernel.org/stable/c/df77a678c33871a6e4ac5b54a71662f1d702335b (opens in a new tab)
- git.kernel.org/stable/c/e2355d513b89a2cb511b4ded0deb426cdb01acd0 (opens in a new tab)
- git.kernel.org/stable/c/04e85a3285b0e5c5af6fd2c0fd6e95ffecc01945 (opens in a new tab)
- git.kernel.org/stable/c/7253b4fed46471cc247c6cacefac890a8472c083 (opens in a new tab)
- git.kernel.org/stable/c/78c6e39fef5c428960aff742149bba302dd46f5a (opens in a new tab)
- git.kernel.org/stable/c/81c68e218ab883dfa368460a59b674084c0240da (opens in a new tab)
- git.kernel.org/stable/c/a4e772898f8bf2e7e1cf661a12c60a5612c4afab (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7100-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7100-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7088-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-7119-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7123-1 (opens in a new tab)