CVE-2024-48990: needrestart · Uncontrolled Search Path Element
Affects needrestartSource GCVE Database
Public exploit available (Metasploit) · CVSS 7.8 High : upgrade to 3.8 as a priority.
Data as of 30 Oct 2026, 02:24 UTC
Thin evidence
One scorer or none| CNA (canonical) | CVSS 3.1 | 7.8 |
|---|
- Patch
- Available – fixed in 3.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Nov 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade needrestart to 3.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| needrestart needrestart | Affected
| Fixed in
|
AI-suggested
A fixed version 3.8 of needrestart is available that addresses this vulnerability. Users should upgrade to version 3.8 or later to remediate this issue. No other mitigations are indicated.
Description
CVE-2024-48990 is a vulnerability in needrestart before version 3.8 that allows local attackers to execute arbitrary code as root. This occurs because needrestart improperly handles the PYTHONPATH environment variable, enabling an attacker to control the Python interpreter's search path.
References
- cve.org/CVERecord?id=CVE-2024-48990 (opens in a new tab)
- github.com/liske/needrestart/commit/fcc9a4401392231bef4ef5ed026a0d7a275149ab (opens in a new tab)
- qualys.com/2024/11/19/needrestart/needrestart.txt (opens in a new tab)
- openwall.com/lists/oss-security/2024/11/19/1 (opens in a new tab)
- seclists.org/fulldisclosure/2024/Nov/17 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/11/msg00014.html (opens in a new tab)