Skip to main content
VulnerabilityPublished Updated

CVE-2024-48992: needrestart · Uncontrolled Search Path Element

Affects needrestartSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.8 High : upgrade to 3.8 soon.

Data as of 30 Oct 2026, 02:24 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (canonical)CVSS 3.17.8
Patch
Available – fixed in 3.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade needrestart to 3.8.

Affected software

ProductAffectedFixed in
needrestart needrestartAffected
  • <3.8
Fixed in
  • 3.8

AI-suggested

Upgrade needrestart to version 3.8 or later where this vulnerability is fixed. Until patched, restrict local user access and avoid running needrestart in untrusted environments.

Description

CVE-2024-48992 is a vulnerability in needrestart before version 3.8 where local attackers can execute arbitrary code as root by manipulating the RUBYLIB environment variable. This occurs due to an uncontrolled search path element (CWE-427) that causes needrestart to run the Ruby interpreter with attacker-controlled library paths.

References

Community reviews

Loading reviews…