CVE-2024-5126: lunary-ai/lunary · Missing Authorization
Affects lunary-ai/lunarySource CVE Database V5
Not known to be exploited · CVSS 7.6 High : upgrade to 1.2.25 soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.2.25
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 6 Jun 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade lunary-ai/lunary to 1.2.25.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHublunary-ai/lunarypkg:github/lunary-ai/lunaryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade lunary-ai/lunary to version 1.2.25 or later, where the vulnerability is fixed. Until patching is possible, restrict network access to the lunary-ai/lunary service to trusted users and networks only, employing network segmentation and firewall rules. Implement strict access controls and monitor user activities related to prompt updates to detect unauthorized changes. Employ application-layer logging and alerting for any anomalous prompt modification attempts. Conduct regular audits of prompt data integrity and review user privilege assignments to minimize risk exposure. Additionally, consider deploying Web Application Firewalls (WAFs) with custom rules to detect and block unauthorized API calls targeting the versions.patch functionality. Finally, educate development and operations teams about the vulnerability to ensure awareness and prompt response to any suspicious activity.
Description
An improper access control vulnerability exists in the lunary-ai/lunary repository, specifically within the versions.patch functionality for updating prompts. Affected versions include 1.2.2 up to but not including 1.2.25. The vulnerability allows unauthorized users to update prompt details due to insufficient access control checks. This issue was addressed and fixed in version 1.2.25.