CVE-2024-5130: lunary-ai/lunary · Missing Authorization
Affects lunary-ai/lunarySource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 1.2.8 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.2.8
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Jun 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade lunary-ai/lunary to 1.2.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHublunary-ai/lunarypkg:github/lunary-ai/lunaryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The primary mitigation is to upgrade lunary-ai/lunary to version 1.2.8 or later, where the authorization checks have been properly implemented. Organizations should immediately inventory their deployments to identify affected versions and apply the update. In addition to patching, organizations should implement strict access controls and monitoring around dataset management APIs to detect and prevent unauthorized deletion attempts. Employing network segmentation and firewall rules to restrict access to the lunary-ai management interfaces can reduce exposure. Logging and alerting on dataset deletion events should be enabled to provide early detection of suspicious activity. Conducting regular audits of dataset ownership and permissions can help identify anomalies. Finally, organizations should consider implementing backup and recovery procedures for datasets to mitigate the impact of any unauthorized deletions that may occur before patching.
Description
An Incorrect Authorization vulnerability exists in lunary-ai/lunary versions up to and including 1.2.2, which allows unauthenticated users to delete any dataset. The vulnerability is due to the lack of proper authorization checks in the dataset deletion endpoint. Specifically, the endpoint does not verify if the provided project ID belongs to the current user, thereby allowing any dataset to be deleted without proper authentication. This issue was fixed in version 1.2.8.