Skip to main content
VulnerabilityPublished

CVE-2024-51337: core · Cross-site Scripting

Affects coreSource CVE Database V5

0

Not known to be exploited · CVSS 3.5 Low : upgrade to 27.0.01 when convenient.

Data as of 26 Oct 2026, 12:29 UTC

CVSS 3.1 base score
3.5Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 27.0.01
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gibbonedu/core to 27.0.01.

Affected software

ProductAffectedFixed in
GitHubgibbonedu/corepkg:github/gibbonedu/coreOther threatsAffected
  • <27.0.01
Fixed in
  • 27.0.01

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2024-51337, organizations should upgrade Gibbon installations to version 28.0.00 or later, where the vulnerability is fixed. In addition to patching, administrators should implement strict input validation and output encoding for all user-supplied data, especially parameters like email addresses in administrative modules. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers. Limit user privileges to the minimum necessary to reduce the risk of exploitation by low-privilege attackers. Educate users and administrators about the risks of clicking on suspicious links or interacting with untrusted content within the application. Regularly audit and monitor logs for unusual activity related to user management functions. If immediate patching is not feasible, consider disabling or restricting access to the vulnerable module temporarily. Finally, maintain an up-to-date inventory of Gibbon versions deployed to ensure timely application of security updates.

Description

Cross Site Scripting vulnerability in Gibbon before v.27.0.01 and fixed in v.28.0.00 allows a remote attacker to obtain sensitive information via the email parameter found in /Gibbon/modules/User Admin/user_manage_editProcess.php.

References

Community reviews

Loading reviews…