Skip to main content
CVE-2024-5200VulnerabilityPublished Updated

CVE-2024-5200: Postie (WordPress plugin) · Cross-Site Scripting (XSS)

Affects Postie (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 4.8 Medium.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
PostieAffected
  • =0
Fixed in–

AI-suggested

1. Immediately update the Postie plugin to version 1.9.71 or later once the patch is released to ensure proper sanitization and escaping of settings. 2. Restrict administrative privileges strictly to trusted personnel and enforce strong authentication mechanisms such as multi-factor authentication (MFA) to reduce the risk of compromised admin accounts. 3. Regularly audit WordPress user roles and capabilities, especially in multisite environments, to ensure that only necessary users have high-level privileges. 4. Implement Content Security Policy (CSP) headers to limit the impact of potential XSS attacks by restricting the sources of executable scripts. 5. Monitor WordPress logs and plugin activity for unusual behavior indicative of attempted exploitation. 6. Educate administrators about the risks of stored XSS and safe plugin configuration practices. 7. Consider deploying web application firewalls (WAF) with rules tuned to detect and block XSS payloads targeting WordPress plugins. 8. Backup WordPress sites regularly to enable quick recovery in case of compromise.

Description

The Postie WordPress plugin before 1.9.71 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

References

Community reviews

Loading reviews…