Skip to main content
CVE-2024-52947VulnerabilityPublished Updated

CVE-2024-52947: n/a

Source CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium · fixed in 2.20.1 : update LemonLDAP::NG when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Affects
LemonLDAP::NG before 2.20.1
Patch
Available – fixed in 2.20.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

AI-suggested

Administrators should immediately verify whether the 'Upgrade session' plugin is enabled in their LemonLDAP::NG deployments and assess exposure of the upgrade session confirmation page. If you cannot patch yet, consider disabling the 'Upgrade session' plugin if it is not essential to reduce attack surface. Implement strict input validation and output encoding on the 'url' parameter to prevent injection of malicious scripts. Employ Content Security Policy (CSP) headers to restrict execution of unauthorized scripts in browsers. Conduct user awareness training to mitigate risks from phishing or social engineering that could trigger user interaction. Monitor web server logs for suspicious requests targeting the 'url' parameter or unusual session upgrade attempts. Plan and prioritize upgrading to LemonLDAP::NG version 2.20.1 or later once the patch is released. Additionally, review and tighten administrative privileges to limit who can enable potentially risky plugins. Deploy web application firewalls (WAF) with rules to detect and block XSS payloads targeting this vulnerability. Finally, integrate vulnerability scanning and penetration testing focused on authentication components to detect similar issues proactively.

Description

A cross-site scripting (XSS) vulnerability in LemonLDAP::NG before 2.20.1 allows remote attackers to inject arbitrary web script or HTML via the url parameter of the upgrade session confirmation page (upgradeSession / forceUpgrade) if the "Upgrade session" plugin has been enabled by an admin

References

Community reviews

Loading reviews…