Skip to main content
VulnerabilityPublished Updated

CVE-2024-53930: WikiDocs · Cross-site Scripting

Affects WikiDocsSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.0.65 when convenient.

Data as of 26 Oct 2026, 11:07 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.65
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade zavy86/WikiDocs to 1.0.65.

Affected software

ProductAffectedFixed in
GitHubzavy86/WikiDocspkg:github/zavy86/WikiDocsOther threatsAffected
  • <1.0.65
Fixed in
  • 1.0.65

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2024-53930, organizations should immediately upgrade WikiDocs to version 1.0.65 or later, where the vulnerability has been addressed. If upgrading is not immediately feasible, implement strict input validation and sanitization on user-submitted content, especially for sequences involving $$\\ that trigger KaTeX parsing. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts and reduce the impact of potential XSS payloads. Limit the number of users with content editing privileges and enforce strong authentication mechanisms to reduce the risk of malicious insider activity. Regularly audit and monitor WikiDocs content for suspicious scripts or anomalies. Additionally, educate users about the risks of XSS and encourage cautious interaction with untrusted content. Finally, maintain an incident response plan to quickly address any detected exploitation attempts.

Description

WikiDocs before 1.0.65 allows stored XSS by authenticated users via data that comes after $$\\, which is mishandled by a KaTeX parser.

References

Community reviews

Loading reviews…