CVE-2024-5416: Elementor Website Builder (WordPress plugin) · Cross-site Scripting
Affects Elementor Website Builder (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 5.4 Medium · fixed in 3.23.2 : update Elementor Website Builder (WordPress plugin) when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.23.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Sep 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| elemntor Elementor Website Builder – more than just a page builder | Affected
| Fixed in– |
AI-suggested
A partial fix was introduced in version 3.23.2, but versions up to 3.23.4 remain vulnerable. Users should monitor official Elementor communications for a full patch or update beyond 3.23.4. Until a confirmed fix is available, restrict contributor-level access to trusted users only and consider additional input validation or content security policies to mitigate risk.
Description
The Elementor Website Builder – More than Just a Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the url parameter of multiple widgets in all versions up to, and including, 3.23.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in Elementor Editor pages. This was partially patched in version 3.23.2.
References
- wordfence.com/threat-intel/vulnerabilities/id/a99a64f7-1ea8-4de6-b24f-1f69bf25c1f5?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/elementor/tags/3.21.8/includes/widgets/traits/button-trait.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/elementor/tags/3.21.8/includes/widgets/image.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/elementor/tags/3.21.8/includes/widgets/social-icons.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/elementor/tags/3.21.8/includes/widgets/testimonial.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3123936 (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3149264/ (opens in a new tab)