Skip to main content
VulnerabilityPublished Updated

CVE-2024-56145: craftcms cms · Code Injection

Affects craftcms cmsSource CVE Database V5

0

Exploited in the wild · KEV due 23 Jun 2025 · public exploit available (Metasploit) · 97% EPSS · fixed in 5.5.2 : patch craftcms cms now.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
EPSS
97.4% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.2, 4.13.2, 3.9.14
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 18 Dec 2024

  2. Weaponised: evidence found.

    1 Metasploit module

  3. Exploited in the wild: evidence found.

    Listed in CISA KEV 166 days after disclosure

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by GitHub, Inc.

    , 2 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. , 166 days after disclosure

  4. KEV remediation due

    US federal deadline

    , 187 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade craftcms/cms to 5.5.2, 4.13.2 or 3.9.14.

Affected software

ProductAffectedFixed in
GitHubcraftcms/cmspkg:github/craftcms/cmsOther threatsAffected
  • <3.9.14
  • <4.13.2
  • <5.5.2
Fixed in
  • 3.9.14
  • 4.13.2
  • 5.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should disable `register_argc_argv` to mitigate the issue.

References

Community reviews

Loading reviews…