CVE-2024-58304: SPA-CART CMS · Cross-site Scripting
Affects SPA-CART CMSSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 2.0.0 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade SPA-CART CMS to 2.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SPA-CartSPA-CART CMS | Affected
| Fixed in
|
AI-suggested
In the meantime, restrict administrator access to trusted personnel only and consider additional input validation or sanitization controls on the 'descr' parameter if possible. Avoid using the vulnerable version 1.9.0.3 in production environments until a fix is released.
Description
SPA-CART CMS before 2.0.0 contains a stored cross-site scripting vulnerability in the product description parameter that allows authenticated administrators to inject malicious scripts. Attackers can submit JavaScript payloads through the 'descr' parameter in the product edit form to execute arbitrary code in administrative users' browsers.