Skip to main content
VulnerabilityPublished Updated

CVE-2024-58363: surrealdb · Improper Authentication

Affects surrealdbSource GCVE Database

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.5.4 when convenient.

Data as of 27 Oct 2026, 20:28 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.5.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade surrealdb to 1.5.4.

Affected software

ProductAffectedFixed in
surrealdb surrealdbAffected
  • <1.5.4
Fixed in
  • 1.5.4

AI-suggested

A fix is available in SurrealDB version 1.5.4 and later. Users should upgrade to version 1.5.4 or newer to resolve the improper authentication issue. No additional mitigation steps are indicated in the provided data.

Description

SurrealDB versions before 1.5.4 contain an authentication validation flaw. When a user switches databases using the USE clause or use method, the system fails to properly validate authentication. This allows an authenticated user to impersonate another user in a different database if a user record with the same identifier exists. Unauthorized actions can occur if permissions are based solely on the $auth parameter.

References

Community reviews

Loading reviews…