CVE-2024-5945: WP SVG Images · Cross-site Scripting
Affects WP SVG ImagesSource CVE Database V5
Not known to be exploited · CVSS 6.4 Medium · fixed in 4.4 : update WP SVG Images when convenient.
Data as of 26 Oct 2026, 15:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Jun 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| shortpixel WP SVG Images | Affected
| Fixed in– |
AI-suggested
Users should upgrade the WP SVG Images plugin to version 4.4 or later, where the vulnerability is fully fixed. Version 4.3 included a patch, but it was bypassed, so only version 4.4 or newer provides complete remediation. Since this is not a cloud service, remediation depends on applying the official plugin update. Patch status is not explicitly stated in the input but can be inferred from the description; however, users should verify the vendor advisory for the latest guidance.
Description
The WP SVG Images plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘type’ parameter in all versions up to, and including, 4.3 due to insufficient input sanitization. This makes it possible for authenticated attackers, with Author-level access and above, who have permissions to upload sanitized files, to bypass SVG sanitization and inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A bypass to the patch in version 4.3 was discovered and fixed completely in version 4.4.
References
- wordfence.com/threat-intel/vulnerabilities/id/389d96e9-1fad-49a6-89b6-8f7f108d8117?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/wp-svg-images/trunk/wp-svg-images.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/wp-svg-images/trunk/wp-svg-images.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3105276/ (opens in a new tab)
- plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3227378%40wp-svg-images&new=3227378%40wp-svg-images&sfp_email=&sfph_mail= (opens in a new tab)