Skip to main content
CVE-2024-6508VulnerabilityPublished Updated

CVE-2024-6508: openshift-console · Insufficient Entropy

Affects openshift-consoleSource CVE Database V5

0

Not known to be exploited · CVSS 8.0 High : upgrade to 4.17.1 or 4.13.54 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.17.1, 4.13.54
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade redhat/openshift-console to 4.17.1 or 4.13.54.

Affected software

ProductAffectedFixed in
Red Hatredhat/openshift-consolepkg:rpm/redhat/openshift-consoleOther threatsAffected
  • <4.13.54 >=4.13.0
  • <4.17.1 >=4.17.0
Fixed in
  • 4.13.54
  • 4.17.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released official security updates addressing CVE-2024-6508 in OpenShift Container Platform versions 4.13.54 and 4.17.1. Users should upgrade their OpenShift clusters to these versions or later as soon as possible using the OpenShift CLI (oc) or web console. The vendor manages remediation for these on-premise deployments via these updates. No additional mitigation steps are indicated beyond applying the official patches.

Description

An insufficient entropy vulnerability was found in the Openshift Console. In the authorization code type and implicit grant type, the OAuth2 protocol is vulnerable to a Cross-Site Request Forgery (CSRF) attack if the state parameter is used inefficiently. This flaw allows logging into the victim’s current application account using a third-party account without any restrictions.

References

Community reviews

Loading reviews…