CVE-2024-7055: FFmpeg · Heap-based Buffer Overflow
Affects FFmpegSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium.
Data as of 26 Oct 2026, 09:15 UTC
- EPSS
- 1.4% chance of exploitation in 30 days – higher than 72% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubffmpeg/FFmpegpkg:github/ffmpeg/FFmpegOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. Immediately upgrade all FFmpeg instances to version 7.0.2 or later to apply the official patch addressing the heap overflow. 2. Audit all applications and services that utilize FFmpeg for media decoding or processing to identify vulnerable versions. 3. Implement network-level filtering to restrict or monitor incoming media streams from untrusted sources. 4. Employ sandboxing or containerization for media processing components to limit the impact of potential exploitation. 5. Integrate input validation and sanitization for media files before processing with FFmpeg, where feasible. 6. Monitor logs and network traffic for anomalous activity indicative of exploitation attempts targeting media processing pipelines. 7. Coordinate with vendors and third-party service providers to ensure they have applied the patch or mitigations. 8. Maintain an incident response plan tailored to media infrastructure compromise scenarios.
Description
A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.
References
- vuldb.com (opens in a new tab)
- vuldb.com (opens in a new tab)
- vuldb.com (opens in a new tab)
- github.com/CookedMelon/ReportCVE/tree/main/FFmpeg/poc3 (opens in a new tab)
- ffmpeg.org/download.html (opens in a new tab)
- ffmpeg.org (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/10/msg00019.html (opens in a new tab)