CVE-2024-7923: Improper Authentication
Source CVE Database V5
Not known to be exploited · CVSS 9.8 Critical.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 4 Sep 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
AI-suggested
To mitigate CVE-2024-7923, organizations should take the following specific actions: 1) Upgrade Gunicorn to version 22.0 or later to address the underlying issue with header handling. 2) Apply any available patches or updates from Red Hat for Satellite and Pulpcore components as soon as they are released. 3) Review and modify Apache mod_proxy configurations to ensure headers with underscores are properly sanitized or blocked, potentially by disabling or restricting the use of such headers. 4) Implement network segmentation and restrict access to Satellite servers to trusted management networks only, minimizing exposure to untrusted sources. 5) Monitor logs for unusual or malformed HTTP headers that could indicate exploitation attempts. 6) Employ Web Application Firewalls (WAFs) or reverse proxies capable of detecting and blocking malformed headers or suspicious authentication bypass attempts. 7) Conduct thorough audits of Satellite administrative accounts and credentials to detect any unauthorized access. 8) Prepare incident response plans specific to Satellite compromise scenarios to enable rapid containment and recovery.
Description
An authentication bypass vulnerability has been identified in Pulpcore when deployed with Gunicorn versions prior to 22.0, due to the puppet-pulpcore configuration. This issue arises from Apache's mod_proxy not properly unsetting headers because of restrictions on underscores in HTTP headers, allowing authentication through a malformed header. This flaw impacts all active Satellite deployments (6.13, 6.14 and 6.15) which are using Pulpcore version 3.0+ and could potentially enable unauthorized users to gain administrative access.
References
- access.redhat.com/errata/RHSA-2024:6335 (opens in a new tab)
- access.redhat.com/errata/RHSA-2024:6336 (opens in a new tab)
- access.redhat.com/errata/RHSA-2024:6337 (opens in a new tab)
- access.redhat.com/errata/RHSA-2024:8906 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2024-7923 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2305718 (opens in a new tab)