Skip to main content
CVE-2024-8756VulnerabilityPublished Updated

CVE-2024-8756: Quform (WordPress plugin) · Information Exposure

Affects Quform (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
ThemeCatcher Quform - WordPress Form BuilderAffected
  • =0
Fixed in–

AI-suggested

Upgrade the Quform plugin to version 2.21.0 or later to address the vulnerability in new forms. For full remediation, site administrators must download and securely store any previously uploaded files, delete all previously existing files and forms created before the upgrade, and then recreate the forms after upgrading. This manual cleanup is necessary because files uploaded via older forms remain vulnerable despite the plugin update. No automated patch or fix is available for previously uploaded files.

Description

The Quform - WordPress Form Builder plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.20.0 via the 'saveUploadedFile' function. This makes it possible for unauthenticated attackers to extract sensitive data, such as Personally Identifiable Information, from files uploaded by users. Files uploaded via forms created before version 2.21.0 will remain vulnerable to exposure after upgrading. To fully patch the plugin, site administrators should download any previously uploaded files, delete previously existing files and forms, and create the forms again after upgrading to version 2.21.0.

References

Community reviews

Loading reviews…