Skip to main content
VulnerabilityPublished Updated

CVE-2024-8932: PHP · Out-of-bounds Write

Affects PHPSource CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical · fixed in 8.3.14 : patch PHP as a priority.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.2% chance of exploitation in 30 days – higher than 69% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.3.14, 8.2.26, 8.1.31
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade php/php-src to 8.3.14, 8.2.26 or 8.1.31.

Affected software

ProductAffectedFixed in
GitHubphp/php-srcpkg:github/php/php-srcOther threatsAffected
  • >=8.1.0 <8.1.31
  • >=8.2.0 <8.2.26
  • >=8.3.0 <8.3.14
Fixed in
  • 8.1.31
  • 8.2.26
  • 8.3.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately audit their PHP environments to identify versions 8.1.*, 8.2.*, and 8.3.* running on 32-bit systems. The primary mitigation is to upgrade PHP to versions 8.1.31, 8.2.26, or 8.3.14 or later, where the vulnerability is patched. If immediate upgrading is not feasible, organizations should implement input validation and sanitization to limit the length of strings passed to ldap_escape() and other LDAP-related functions. Employing web application firewalls (WAFs) to detect and block suspicious LDAP-related payloads can provide temporary protection. Additionally, organizations should review and restrict access to PHP applications handling LDAP inputs, enforce least privilege principles, and monitor logs for anomalous activity indicative of exploitation attempts. For legacy 32-bit systems, consider migration to supported 64-bit platforms to reduce exposure. Regular vulnerability scanning and penetration testing focused on LDAP and PHP components will help detect exploitation attempts early.

Description

In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, uncontrolled long string inputs to ldap_escape() function on 32-bit systems can cause an integer overflow, resulting in an out-of-bounds write.

References

Community reviews

Loading reviews…